Browse forums 
Ankama Trackers

How to change the language back?

By ZZekses#3061 June 30, 2017, 23:23:24

Some time since I last logged in krosmaga decided it wants to be in Russian.
I hate playing in russian,it feels unnatural and makes card discussion hard with english speaking people. How do I switch back to english?

0 0
Reactions 1

If you're on PC/Mac, go to your updater. Click on the Options cogwheel, then click "Interface" and select your language here. (You'll have to restart the updater but the game will be launched with the language selected there.)

If you're on mobile, log off from your account, then select your language on the login screen. 

If you're on Steam, right-click on Krosmaga in your game library, then select "Properties" and then the Language tab. 

Respond to this thread